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Abstract

Using Zotero with LYX enables CWYW (Cite-While-You-Write) capabilities in LYX,
greatly simplifying the process of adding references in LYX. Follow the steps in this
guide to get Zotero and LYX working together.
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1 Zotero and LYX

Zotero is an open-source reference management software. It collaborates very well with Firefox, Chrome
or Safari and makes it easy to collect, organize, cite and share research sources. This guide will walk you
through how to install Zotero and link it to LYX to enable CWYW (Cite-While-You-Write) capabilities in
LYX.

Why is this important? TEX (which is what LYX is built upon) uses BiBTEX and *.bib files to manage
references. A *.bib file is a text file which contains references in the following format:

@article{solow1956contribution,
title={A contribution to the theory of economic growth},
author={Solow, Robert M},
journal={The quarterly journal of economics},
volume={70},
number={1},
pages={65–94},
year={1956},
publisher={Oxford University Press} }

BibTEX then interprets this information to create in-text citation and bibliographies.

LYX does possess a built in citation engine that you can implement by inserting a BibTEX bibliography to a
LYX document and then using the insert -> citation command. However, every time you add a new reference
to your list of references you must first update the *.bib file that is associated with your LYX document. This
becomes a very cumbersome process, especially if you are constantly adding references. The better solution
is to use Zotero and LYX together, which allows Zotero to dynamically update your *.bib file, which allows
you to to free yourself from managing your own *.bib file and focus on writing (and citing).

2 Installation Walkthrough

Note: To use LYX with Zotero you have two options: (1) use the standalone version of Zotero or (2) use
the Firefox Add-on version of Zotero. The CWYW capabilities depend on using a Firefox add-on, however
you can install this add-on to the standalone version. The first option is generally preferred as it does not
involve changing browsers , however directions for both are included in this documentation.1

2.1 Installing Zotero (Standalone)

To install Zotero Standalone follow these step-by-step instructions:

1. Open an internet browser and navigate to https://www.zotero.org/.

1Chrome users tend to lament Firefox (and visa-versa). Attempting to convince your Chrome-using coauthors to use Zotero
for Firefox is not recommended.
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2. Click on the Red Button that says, “Install Zotero 4.0 for Windows” (or Mac or Linux depending on
your OS)

3. Save the file and then run the installation file.

4. Now install the Zotero Browser Extension for your favorite browser (Firefox, Safari and Chrome are
supported2) here: https://www.zotero.org/download
You’ll find the browser extensions just below the download link you used to get the Zotero installation
file.

5. Register for a Zotero Account (Click on the Register Button at the top-right corner of the screen)

6. Link your Zotero Account to your Zotero Standalone Application by following the next steps:

(a) Open Zotero in Firefox

(b) Click on the actions menu button (the ’gear’ icon) at the top left column and select “Preferences”

(c) Navigate to the Sync tab and enter your username and password

Now Zotero is installed on your computer and sycned with your Zotero account.

2.2 Installing Zotero (Using Firefox)

Follow these step-by-step instructions for installing Zotero for Firefox:

1. Open Firefox and Visit https://www.zotero.org/ and click on the large red “Download Now” button

2. Click on the Red Button that says, “Install Zotero 4.0 for Firefox” (There may be a different version
number)

3. Follow the prompts necessary to install the Add-on to Firefox.

4. Register for a Zotero Account (Click on the Register Button at the top-right corner of the screen)

5. Link your Zotero Account to your Zotero Firefox Add-on by following the next steps:

(a) Open Zotero in Firefox

(b) Click on the actions menu button (the ’gear’ icon) at the top left column and select “Preferences”

(c) Navigate to the Sync tab and enter your username and password

Now Zotero is installed on your computer and your computer is synced with your Zotero account. If you’d
like you may install the Standalone version of Zotero as well, however it is not necessary. If you do decide to
install the Standalone version, follow the steps in section 2.1 to ensure that you may use CWYW capabilities
in LYX.

2Sorry IE users.

2



2.3 Adding a Reference to Zotero

We’ll need at least one reference in Zotero to test that Zotero is linked with LYX. We’ll use Google Scholar
for this example, however you can find a list of websites that Zotero automatically supports for scraping
bibliographic information here: http://www.zotero.org/support/translators

1. Open your favorite browser and navigate to Google Scholar. If you are using a browser in conjunction
with the standalone version of Zotero ensure that you have installed the proper browser extension (see
2.1 step 4). If you are using the Firefox version of Zotero no extra add-ons are required.

2. Search for “A contribution to the theory of economic growth”

3. Instead of citing directly from Google Scholar it is recommended to cite directly from the journal
webpage. To do this follow the link in Google.

(a) Note: Since JSTOR or DOI URLs tend to me more stable it is recommended that citations are
imported with one of those two features. For this reason, it might make more sense to first search
for the paper you are interested in using JSTOR and then use Google Scholar if JSTOR does not
index that reference.

4. Now, you can cite the paper directly from this page using the button indicated below:

5. When you click this button you’ll notice a box that looks like the picture below show up in the lower
right hand corner of your browser window.3

3Now, with this particular paper the PDF version is not automatically linked with Zotero, however if you add a citation via
JSTOR and the full-text PDF is available to you Zotero will automatically add to the PDF to your Zotero database. Zotero
will also remember the URL of the citation and you can quickly navigate back to the journal website easily.
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6. Navigate to your Zotero application (either Standalone or Firefox version) to confirm that the reference
was added.

7. Confirm that the citation was recorded as intended. It is a good thing to get in a habit of doing this
right after you import references, this was you are certain that your references are correct.

Now you have your first reference in Zotero. For more information about Zotero you can find extensive
documentation at: https://www.zotero.org/support/. Now we’ll continue with our main purpose, allowing
you to CWYW using LYX and Zotero.

2.4 Linking Zotero and LYX�
�

�
�

Note: This tutorial assumes that you already have LYX installed. To install LYX visit:
http://www.lyx.org/Download. The package you find at this location will install a fully functional LYX
setup including a LATEX distribution and a bibliography manager.

Enabling Zotero to have CWYW capabilities involves a few steps and is only possible because of a Firefox
add-on called LyZ, which was developed by Petr Ŝimon. The following directions will have you download
LyZ and link LYX (and LyZ) with Zotero. Again, there are separate directions for users of the Firefox version
of Zotero and the Standalone version of Zotero.

2.4.1 Zotero Standalone

To install LyZ for Zotero Standalone you have to first install Firefox so that you can download the .xpi file
that is necessary to include LyZ with Zotero. I’m searching for a way to host this file so that you won’t have
to do this step, but this is the only way to ensure you get the most up-to-date build of LyZ.

1. Download Firefox at http://www.mozilla.org/en-US/firefox/new/ or continue to step 2 if you already
have Firefox.

2. Open Firefox and goto: https://addons.mozilla.org/en-US/firefox/addon/lyz/

3. Right click on the + Add to Firefox Button and press Save Link As...

4. Save the file lyz-2.1.7-fx.xpi in your directory of choice

5. Open Zotero Standalone and goto Tools > Addons and click on the Mixer button (looks like this )

6. Click Install add-on from file, select the lyz-2.1.7-fx.xpi and press the open button.
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7. Press Install Now and restart Zotero.

8. Your Zotero should now have a LyZ Menu (it will look like this )

9. Now open LYX and goto Tools > Preferences > Paths and set LYXServer pipe to \\. pipe\lyxpipe

(a) If you use Linux or Mac: set LYXServer pipe to ~/.lyxpipe

(b) If you use Linux or Mac: Open LyZ and goto LyZ menu > Preferences and set Lyx server to
~/.lyxpipe

10. Proceed to Section 2.5

2.4.2 Zotero for Firefox

1. Open Firefox and install the LyZ add-on. The link can be found here: https://addons.mozilla.org/en-
US/firefox/addon/lyz/

2. After the add-on is installed, restart Firefox. When Firefox restarts navigate to your Zotero tab and
you should now see the LyZ menu (it will look like this )

3. Now open LYX and goto Tools > Preferences > Paths and set LYXServer pipe to \\. pipe\lyxpipe

(a) If you use Linux or Mac: set LYXServer pipe to ~/.lyxpipe

(b) If you use Linux or Mac: Open LyZ and goto LyZ menu > Preferences and set Lyx server to
~/.lyxpipe

4. Now Goto Tools > Reconfigure and restart LYX.

5. Close LYX and Firefox and proceed to section 2.5.

2.5 Inserting Citations and Compiling a Bibliography in LYX

Now that LYX, LyZ and Zotero are set up, we can use the CWYW capability of LyZ and Zotero to add a
citation directly to a LYX document. Follow the directions below to pipe your first Zotero citation to LYX!

1. Open LYX and create a new document.

2. Open Zotero and select a citation and from either the LyZ menu or by right clicking on the citation
and choosing “Cite in LYX”
(Note: You may also select more than one citation to cite more than one reference at a time.)

3. You will be prompted to create a new BibTEX database. Press “OK” and name and save this file.
Preferably save this file where your LYX document will be saved.
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Your LYX window should now look like this:

4. Now, insert the BibTEX database you just saved into the LYX document by clicking Insert > List/TOC
>BibTEX Bibliography and selecting your newly created *.bib file as the database.
Your LYX window should now look like this:

5. Compile your document by pressing the button. If you are a new user of LYX (and not using the
IPA template provided) your document settings will make it so that when you compile the document
your citations and bibliography will look like this:

6. To get your citation into the (Author, Year) format follow the next steps:

(a) In LYX go to Document > Settings > Bibliography

(b) Change Citation Style to Natbib and set Natbib style to Author-year
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(c) On your LYX terminal click on the gray highlighted text: BibTEX Generated Bibliography

(d) Change the Style to plainnat

(e) Goto Document > Settings > Document Class and in the Custom bar type round.
(This step ensures that your citations will be set off by parentheses and not brackets)

(f) Compile you document by pressing the button and now your output should look like this:

7. To add more Citations simply select the citation or citations in Zotero and choose “Cite in LYX”. Your
*.bib file will automatically update so that you may CWYW without having to constantly update your
*.bib file.

8. If you modify the reference information of previously cited items in Zotero, use the “Update BibTEX”
option from the LyZ menu to update the BibTEX database.

2.6 Dealing with Citations Styles in LYX

You can edit the appearance of your citations in LYX by clicking on the gray highlighted text of a citation in
LYX. However, it is important to note that you cannot edit citations added by Zotero without first saving
your document. So to edit the appearance of your citations in a LYX document follow these steps:

1. Add a reference from Zotero to LYX.

2. Save your document.

3. Click on the gray highlighted text in LYX that is associated with the citation you wish to edit. You
should see a menu like below:
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4. Choose your preferred style and now your citation will reflect that style.

Now let us assume we want our citation to say: (See Solow 1956 for a clear explanation of this concept). It
seems that we could choose the –Solow 1956– style, enter the text “(See ” into the Text before field and “
for a clear explanation of this concept)” into the text after field, however this doesn’t work as seamlessly as
we would like. If we try that we get this result in the compiled LYX document:

Instead use the following workaround to achieve the desired citation:

1. Set the citation style to –Add to bibliography only–

2. Navigate to where you want the citation and manually type “(See Solow 1956 for a clear explanation
of this concept)”. You output in LYX should look like this:

Note that LYX added “(not cited)” to the end of the citation so that you know how this citation is
being treated. This is very helpful for managing your bibliography correctly.

3. Now compile your document and your PDF output will now display the correct citation style:

Now let’s say that you want to update a citation that has incorrect information in it, for example an author’s
name is spelled incorrectly. Let us assume that when we imported our Solow citation that the last name was
incorrectly specified as “Soloow”. Follow these steps to fix broken citations:
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1. Open Zotero and edit the citation information that you want to change. In this case change “Soloow”
to “Solow”

2. In the LyZ Menu in Zotero choose the option: Update BiBTEX. You’ll see the prompt below, press OK.

You’ll see a second prompt:

Press “OK” to this prompt too. Pressing “OK” here will open all LYX documents which used that
Citation and update the corresponding *.bib file. You want to do this to ensure that all of your files
are using the correct bibliographic information.

3 Final Words

Using LYX and Zotero allows you to streamline your references without having to constantly manage a
BibTEX database. If you have problems with Zotero or LYX I recommend you check out their excellent
documentation (http://wiki.lyx.org/LYX/Documentation and http://www.zotero.org/support/).

I’ve only tested this walkthrough using Windows 7, Zotero Version 4.0.15, LYX version 2.0.6 and LyZ version
2.1.7. If you are using another OS please let me know if this tutorial still works. I adapted much of
this tutorial from https://addons.mozilla.org/en-US/firefox/addon/lyz/, http://www.klubko.net/lyz/ and
http://wiki.lyx.org/LYX/Documentation.
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